This project is read-only.

Troubles compiling mono-addins

Oct 16, 2012 at 2:50 PM


I'm trying to compile mono-addins on linux, I've installed from sources:

- mono (the head version from github repository), 

- gtksharp (I tried both head and branch 2.12)

now when I try to compile mono-addins (both from the tarball on codeplex than the head on github) the autogen (or configure) ends successfully but then when I run make I get the following errors:

Building Mono.Addins.Gui.csproj:

error CS1705: Assembly `gdk-sharp, Version=, Culture=neutral, PublicKeyToken=35e10195dab3c99f' references `Mono.Cairo, Version=, Culture=neutral, PublicKeyToken=0738eb9f132ed756' which has a higher version number than imported assembly `Mono.Cairo, Version=, Culture=neutral, PublicKeyToken=0738eb9f132ed756'

Mono.Addins.Gui/HeaderBox.cs(133,47): error CS0012: The type `Cairo.Context' is defined in an assembly that is not referenced. Consider adding a reference to assembly `Mono.Cairo, Version=, Culture=neutral, PublicKeyToken=0738eb9f132ed756'

Can you help me to figure out the problem?



Nov 2, 2012 at 12:45 AM

Go to makefile in the Mono.Addins.Gui project and find ASSEMBLY_COMPILER_FLAGS. Add -sdk:4 after -d:DEBUG and run make again.

Mar 22, 2013 at 6:52 PM
Thank you. This worked.
Jul 18, 2013 at 12:47 AM
Thanks. Worked for me too.
Jan 3, 2014 at 2:43 PM
Thaks. Worked for me too.